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1. การใช้งาน Flash เบื�องต้น 

1.1 การใชง้านโปรแกรมเบื�องตน้ 

การสร้างไฟลใ์หม ่คลิกที�เมนู File -> New คลิกเลือกที� Flash File (Action Script 2.0) แลว้คลิก

ปุ่ม OK ดงัภาพ 

 
การบนัทึกไฟล ์คลิกที�เมนู File -> Save พิมพชื์�อไฟลที์�ตอ้งการ แลว้คลิกปุ่ม Save ดงัภาพ 
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การเปิดไฟล ์เพื�อเอางานกลบัแกไ้ข  คลิกที�เมนู File -> Open คลิกเลือกไฟลที์�ตอ้งการ แลว้กด

ปุ่ม Open ดงัภาพ 

 
เมื�อเราไดส้ร้างไฟลใ์หมม่าแลว้สิ�งแรกที�ควรทาํคือการกาํหนดขนาดของพื�นที�การทาํงาน 

(Stage)  มีขั�นตอน ดงันี�  

1) ที� Panel ของ Properties ให ้พิมพข์นาดของพื�นที�การทาํงานในช่อง Dimensions  

 ดงัภาพ 
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1.2 การใช้งานเครื;องมือต่างๆ (Tools) 

การวาดรูปทรงต่างๆ เช่น รูปสี�เหลี�ยม มีขั�นตอนดงันี�   

1) คลิกที�เครื�องมือ Rectangle Tool  ดงัภาพ 

 
2) กาํหนดคุณสมบติัของวตัถุ (สี� เหลี�ยม) เช่น สีพื�น หรือ สีเส้นขอบเป็นตน้ ดงัภาพ 

 
3) คลิกที�พื�นที�การทาํงาน (Stage) แลว้ลากเมาส์ เพื�อกาํหนดขนาดของสี�เหลี�ยมที�ตอ้งการ 

ดงัภาพ 
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การใชเ้ครื�องมือ Text Tool มีขั�นตอนดงันี�  

1) คลิกเลือกที� Text Tool ดงัภาพ 

 
2) กาํหนดคุณสมบติัต่างๆ ใหก้บัขอ้ความ เช่น สี , ตวัหนา , แบบอกัษร , ขนาดตวัอกัษร 

เป็นตน้ ดงัภาพ 

 
3) คลิกที�พื�นที�การทาํงาน แลว้พิมพต์วัอกัษรที�ตอ้งการ ดงัภาพ 
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1.3 รู้จักกบั Timeline 

 Timeline เป็นแถบแบ่งเวลาของแอนิเมชั�น ออกเป็นส่วนยอ่ยๆ โดยเป็นเหมือนตาราง จะมี

ช่องที�ถูกแบง่ออกมา เป็นช่องเล็กๆ เราเรียกวา่เฟรม (Frame) แต่ละเฟรมสามารถเก็บวตัถุต่างๆ

ที�เราไดส้ร้างหรือวาดขึ�นมา โดยมีหวัอ่านสีแดง (Playhead) วิ�งไปเรื�อยๆ ทาํให้ภาพเปลี�ยนไป

ในแต่ละเฟรมเกิดเป็นภาพเคลื�อนไหว (Animation) ได ้ดงัภาพ 

 
 

1.4 รู้จักกบั Symbols ประเภทต่างๆ 

Flash ประกอบดว้ย Symbol อยู ่3 ประเภทดว้ยกนั ไดแ้ก่ 

1) Graphic เป็น Symbol ที�ใชใ้นการจดักลุ่มของภาพวาดต่างๆ ที�เราไดว้าดลงไปใน Flash 

เช่น รูปสี�เหลี�ยม เป็นตน้ 

2) Button เป็น Symbol ที�ใชส้าํหรับในการสร้างปุ่ม เพื�อโตต้อบกบัผูใ้ชง้าน  

3) Movie Clip เป็น Symbol ที�มี Timeline ยอ่ย ซึ� งเป็นอิสระออกจาก Timeline อื�น 

สามารถควบคุม และกาํหนดคุณสมบติัได ้

   การสร้าง Symbols ใหม ่มีขั�นตอนดงันี�  

1) คลิกที�เมนู Insert -> New Symbol 

  
 



2) ตั�งชื�อของ 

3) วาดวตัถุต่างๆ ลงไปที� 

4) การนาํ 

5) ดูที� Library

ทาํงาน 

6) เราสามารถนาํ 

ขั�นตอนที� 

 

ตั�งชื�อของ Symbol และเลือกประเภทของ Symbol แลว้กดปุ่ม 

วาดวตัถุต่างๆ ลงไปที� Stage ดงัภาพ 

การนาํ Symbol มาใชง้าน ใหก้ลบัมาที� Scene ก่อน ดงัภาพ

Library Panel คลิกเมาส์คา้งที� Symbol จากนั�นลากแลว้ปล่อยที�พื�นที�การ

ทาํงาน (Stage)  

เราสามารถนาํ Symbol ที�สร้างไวแ้ลว้กลบัมาใชไ้ดห้ลายๆครั� งโดยทาํเหมือน

ขั�นตอนที� 5 

7 

 

แลว้กดปุ่ม OK ดงัภาพ 

 

 
ก่อน ดงัภาพ 

 
จากนั�นลากแลว้ปล่อยที�พื�นที�การ

ที�สร้างไวแ้ลว้กลบัมาใชไ้ดห้ลายๆครั� งโดยทาํเหมือน
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2. การทาํงาน Animation เบื�องต้น 

การทาํแอนิเมชั�น แบบ Sharp Tween มีขั�นตอนดงันี�  

1) วาดรูปภาพที�ตอ้งการทาํแอนิเมชั�นในเฟรมที� 1 ดงัภาพ 

 
2) คลิกขวาที�เฟรมสุดทา้ย (สมมติเลือกเฟรมที� 30) คลิกเลือกที� Insert Keyframe ดงัภาพ 

 
3) กดปุ่ม Delete ที�คียบ์อร์ด เพื�อลบภาพ (รูปดาว) ที�วาดขึ�น แลว้วาดรูปใหมขึ่�นมา ที�เฟรมสุดทา้ย 

(เฟรมที� 30) ดงัภาพ 



4) คลิกขวาระหวา่งเฟรมที� 

Create Sharp Tween 

5) กดปุ่ม Enter หรือ Ctrl+Enter 

คอ่ยๆเปลี�ยนรูปร่างเป็นภาพที�สอง 

ดงัภาพ 

ขวาระหวา่งเฟรมที� 1 และ เฟรมสุดทา้ย (ในที�นี�สมมติวา่เฟรมที� 30) แลว้คลิกเลือกที� 

ดงัภาพ 

Ctrl+Enter เพื�อทดสอบ Movie จะไดผ้ลงานภาพวาดภาพแรก 

คอ่ยๆเปลี�ยนรูปร่างเป็นภาพที�สอง (สี� เหลี�ยม)  
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แลว้คลิกเลือกที�  

 
จะไดผ้ลงานภาพวาดภาพแรก (รูปดาว) 
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การทาํแอนิเมชั�น แบบ Classic Tween การทาํงานแอนิเมชั�นแบบ Classic Tween ต่างจากแบบ Sharp 

Tween เล็กนอ้ยคือเมื�อวาดภาพเสร็จแลว้เราจะตอ้งทาํการแปลงภาพวาดนั�นให้เป็น Symbol เสียก่อน

หรือสร้าง Symbol ใหมขึ่�นมากไ็ด ้การทาํแอนิเมชั�นแบบ Classic Tween มีขั�นตอนดงันี�  

1) วาดภาพที�ตอ้งการทาํแอนิเมชั�น ดงัภาพ 

 
2) คลิกหรือดบัเบิ�ลคลิก เพื�อเลือกวตัถุที�เราไดว้าดลงไป แลว้กดปุ่ม F8 ที�คียบ์อร์ด เพื�อเปลี�ยน

รูปทรงต่างๆ ใหเ้ป็น Symbol จากนั�นตั�งชื�อ Symbol และคลิกเลือกประเภทของ Symbol แลว้

คลิกที�ปุ่ม OK ดงัภาพ 
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3) คลิกขวาที�เฟรมสุดทา้ยที�ตอ้งการใหว้ตัถุเคลื�อนไหวไป เช่น เฟรมที� 30 เป็นตน้ แลว้เลือกที� 

Insert Keyframe ดงัภาพ 

 
4) คลิกเมาส์ที�วตัถุแลว้ลากไปยงัตาํแหน่งที�ตอ้งการ ดงัภาพ 

 
5) คลิกขวาระหวา่งเฟรมที� 1 และเฟรมที� 30 คลิกเลือกที� Create Classic Tween ดงัภาพ 



12 

 

 
6) กดปุ่ม Enter หรือ Ctrl+Enter เพื�อทดสอบ Movie จะเห็นภาพการเคลื�อนไหวของวตัถุ 

7) เราสามารถกาํหนดคุณสมบติั (Properties) เพิ�มเติมไดเ้ช่น การหมุนของวตัถุได ้ดงัภาพ 
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3. Action Script เบื�องต้น 

 Action Script คือภาษาแบบ Script ที�เพิ�มความสามารถให้กบั Flash ในดา้นต่างๆ เช่น การโตต้อบ

กบัผูใ้ชง้าน, การสร้างฟอร์มรับขอ้มูล, การจดัการกบัมลัติมีเดีย, การสร้างเกมส์ เป็นตน้ 

 การเขียน Action Script ที�ดีนั�นควรเขียนโคด้แยกออกมาเป็น layer ใหมต่่างหากเพื�อไมใ่หป้ะปนกบั 

layer อื�นๆ การเขียน Action Script มีขั�นตอนดงันี�  

1) สร้าง layer ใหมที่� Timeline และตั�งชื�อวา่ action หรือชื�ออื�นกไ็ด ้ดงัภาพ 

 
2) คลิกเลือกที�เฟรมที� 1 กดปุ่ม F9 ที�คียบ์อร์ดเพื�อเรียกหนา้ต่าง Actions Panel ที�ใชส้าํหรับเขียน

โคด้ ดงัภาพ 

 
3) ลงมือพิมพโ์คด้ Action Script โดยเริ�มที�บรรทดัที� 1 ดงัภาพ 
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ตวัแปร (Variables) 

 ตวัแปร ทาํหน้าที�สําหรับเก็บขอ้มูลต่างๆ โดยสามารถนาํขอ้มูลนั�นกลบัมาใช้งานได้ เช่น ตวัแปร

สําหรับเก็บคะแนนของเกมส์ เป็นตน้ ก่อนการใชง้านตวัแปรทุกครั� ง เราจะตอ้งทาํการประกาศตวัแปร

เสียก่อน เพื�อบอกวา่จะตั�งชื�อตวัแปรวา่อะไร และจะเกบ็ขอ้มูลประเภทไหนในตวัแปรที�ไดป้ระกาศไว ้

1) การประกาศตวัแปร สามารถเขียนโคด้ไดด้งันี�  

 
อธิบาย การประกาศตวัแปรให้เราพิมพขึ์�นตน้ดว้ยคาํวา่ var จากนั�นเวน้วรรคแลว้พิมพชื์�อตวั

แปร (เราเป็นคนตั�งเอง) ใส่เครื�องหมายโคล่อนแลว้พิมพป์ระเภทตวัแปรที�ตอ้งการ เช่น String 

หมายถึงตวัแปรที�เก็บได้เฉพาะตวัอกัษรหรือข้อความ ส่วน Number คือตวัแปรที�เก็บได้

เฉพาะตวัเลข เป็นตน้ 

2) การกาํหนดคา่ใหก้บัตวัแปร เมื�อเราไดป้ระกาศตวัแปรไปแลว้ เรากก็าํหนดค่าให้ตวัแปรที�เราได้

ประกาศไว ้โดยกาํหนดค่าให้ถูกตอ้ง เช่น ถา้ประกาศเป็นประเภท String ก็ให้ใส่เครื�องหมาย

ฟันหนู (double quote) หรือ ถา้เป็น Number ก็ให้ใส่เป็นตวัเลขเท่านั�น ดงัภาพ (บรรทดัที� 4 

และ 5) 

 
3) การเรียกใชต้วัแปร  เมื�อตวัแปรที�สร้างขึ�นไดถู้กกาํหนดค่าเรียบร้อยแลว้เราสามารถนาํตวัแปรที�

มีคา่นี�ไปใชใ้นงานต่างๆ ได ้ถา้ตอ้งการดูคา่ที�ไดก้าํหนดไว ้สามารถใชค้าํสั�ง trace เพื�อทดสอบ

ตวัแปรได ้ดงัภาพ 

ในบรรทดัที� 7 และ 8 
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ลองกดปุ่ม Ctrl+Enter เพื�อทดสอบโปรแกรมที�ไดเ้ขียนขึ�นจะปรากฎหนา้ต่าง output ขึ�นมา ดงั

ภาพ  

 
 

ตัวดําเนินการ (Operators) 

 ตวัดาํเนินการ คือ เครื�องหมายประเภทต่างๆ ที�เรานาํมาใชจ้ดัการตวัแปรที�ไดส้ร้างขึ�น เช่น 

ตวัดาํเนินทางดา้นคณิตศาสตร์ ประกอบดว้ย เครื�องหมายบวก ลบ คูณ หาร เป็นตน้ หากเรา

ตอ้งการผลลพัธ์ที�ไดบ้วกของตวัแปรสองตวัเราสามารถเขียนโคด้ ไดด้งันี�  
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คําสั;งแบบต้องตัดสินใจ (If) 

 ในชีวติประจาํวนัของเราตอ้งพบกบัการตดัสินใจอยูเ่สมอไมเ่วน้แมก้ระทั�งคอมพิวเตอร์กต็อ้งมีการ

ตดัสินใจในการทาํงานบางอยา่ง โดยจะใชค้าํสั�งที�ชื�อวา่ If ในการใชง้าน ตวัอยา่งคาํสั�ง มีดงันี�  

 
อธิบาย  จากบรรทดัที� 8 หมายความวา่ ถา้ตวัแปร x มีคา่นอ้ยกวา่ตวัแปร y จริง ใหพ้ิมพค์าํวา่ x < y โดย

ใหแ้สดงที� Output Panel นั�นเอง 

 

4. การควบคุม Timeline 

Frame  เป็นช่องเล็กๆ ที�อยูบ่น Timeline เราสามารถเขียนคาํสั�งในการควบคุมเพื�อใหห้วัอ่าน (Play 

head) วิ�งไปที�เฟรมใดกไ็ด ้โดยมีคาํสั�ง ดงันี�  

1) คาํสั�ง stop เป็นคาํสั�งใหห้วัอ่านหยดุการทาํงาน 

2) คาํสั�ง play เป็นคาํสั�งใหห้วัอ่านเริ�มวิ�งบน Timeline 

3) คาํสั�ง gotoAndPlay เป็นคาํสั�งที�ใหก้ระโดดไปยงัเฟรมที�ตอ้งการแลว้ใหห้วัอ่านวิ�งต่อไป 

4) คาํสั�ง gotoAndStop เป็นคาํสั�งที�ใหก้ระโดยไปยงัเฟรมที�ตอ้งการแลว้ใหห้วัอ่านหยดุทนัที 

5) คาํสั�ง nextFrame เป็นคาํสั�งเพื�อใหห้วัอ่านเลื�อนไปยงัเฟรมถดัไป 

6) คาํสั�ง prevFrame เป็นคาํสั�งเพื�อใหห้วัอ่านเลื�อนไปยงัเฟรมก่อนหนา้นี�  

ตวัอยา่งการเขียนโคด้ มีดงันี�  
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Scene เป็นเหมือนฉากในภาพยนตร์ที�เราคุน้เคยโดยแบง่ออกเป็นตอนๆ เราสามารถแบ่งงานของเรา

ออกเป็นส่วนๆไดโ้ดยใช ้Scene ทาํใหง่้ายต่อการดูแล และการจดัการกบัชิ�นงานของเรา 

 การสร้าง Scene ใหม ่มีขั�นตอนดงันี�  

1) คลิกที�เมนู Insert -> Scene ดงัภาพ 

 
2) Flash จะเพิ�ม Scene ใหมม่าให ้เราสามารถสลบัไปมาระหวา่ง Scene ได ้โดยคลิกเลือก

ได ้ดงัภาพ 

 
 การเขียนคาํสั�งควบคุม Scene คาํสั�งที�ใชใ้นการควบคุม และจดัการ Scene มีดงันี�  ไดแ้ก่ 

1) คาํสั�ง nextScene เป็นคาํสั�งใหไ้ปยงั Scene ต่อไป 

2) คาํสั�ง prevScene เป็นคาํสั�งใหไ้ปยงั Scene ก่อนหนา้นี�  

3) คาํสั�ง gotoAndPlay เป็นคาํสั�งที�ระบุไดว้า่จะไปที� Scene ไหน และเฟรมที�เทา่ไหร่ของ 

Scene เสร็จแลว้สั�งใหห้วัอ่านเล่นต่อ 

4) คาํสั�ง gotoAndStop เป็นคาํสั�งที�ระบุไดว้า่จะไปที� Scene ไหน และเฟรมที�เทา่ไหร่ของ 

Scene เสร็จแลว้สั�งใหห้วัอ่านหยดุทนัที 

 

 

 

 

 

 



5. การทาํงานกบัปุ่ ม (Buttons) 

 บอ่ยครั� งที�ชิ�นงานที�สร้างขึ�น

เพื�อกระทาํอะไรบางอยา่งเมื�อผูใ้ชก้ดปุ่มใดๆ ได้

1) นาํปุ่มสาํเร็จรูป โดยคลิกเลือกที�

2) ปุ่มต่างๆจะอยูโ่ฟลเดอร์สีเหลือง การเลือกปุ่มใหค้ลิกเลือกที�ปุ่มที�ตอ้งการแลว้ลากไปปล่อยที�

พื�นที�การทาํงาน (Stage)

 

 

 

 

 

บอ่ยครั� งที�ชิ�นงานที�สร้างขึ�นตอ้งการตอบโตก้บัผูใ้ชโ้ดยการกดที�ปุ่ม เราสามารถเขียน 

เพื�อกระทาํอะไรบางอยา่งเมื�อผูใ้ชก้ดปุ่มใดๆ ได ้โดยมีขั�นตอน ดงันี�  

นาํปุ่มสาํเร็จรูป โดยคลิกเลือกที�เมนู Window -> Common Libraries -> Button

ปุ่มต่างๆจะอยูโ่ฟลเดอร์สีเหลือง การเลือกปุ่มใหค้ลิกเลือกที�ปุ่มที�ตอ้งการแลว้ลากไปปล่อยที�

Stage) ดงัภาพ 
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ตอ้งการตอบโตก้บัผูใ้ชโ้ดยการกดที�ปุ่ม เราสามารถเขียน Action Script 

> Buttons ดงัภาพ 

 
ปุ่มต่างๆจะอยูโ่ฟลเดอร์สีเหลือง การเลือกปุ่มใหค้ลิกเลือกที�ปุ่มที�ตอ้งการแลว้ลากไปปล่อยที�



19 

 

3) คลิกที�ปุ่ม แลว้ตั�งชื�อใหก้บัปุ่มที�สร้างขึ�นจากหนา้ต่าง Properties ดา้นล่าง ดงัภาพ 

 
4) สร้าง layer ใหมแ่ลว้ตั�งชื�อวา่ action คลิกที�เฟรมที� 1 แลว้กดปุ่ม F9 เพื�อเรียกหนา้ต่าง Actions 

Panel  

5) เขียนโคด้ Action Script ดงัภาพ 

 
 อธิบาย การเขียนโคด้เราจะตอ้งอา้งถึงชื�อปุ่มที�เราไดส้ร้างในขั�นตอนที� 3 ตามดว้ยเหตุการณ์

ในทีนี� คือ onRelease หมายถึง เมื�อผูใ้ชก้ดที�ปุ่มแลว้ปล่อย จะใหท้าํอะไร โดยที�ภายในวงเล็บปีก

กานี� คือโคด้ในส่วนที�เราสามารถเขียนโค้ดอะไรก็ได้ในการสั�งให้ Flash ทาํงานตามที�เรา

ตอ้งการ   

6. การทาํงานกบัข้อความ (Text) 

 เพื�อให้ไดง้านที�น่าสนใจเราควรมีตวัอกัษรประกอบในงานของเรา ในที�นี� เราจะใชเ้ครื�องมือที�ชื�อวา่ 

Text Tool โดยเครื�องมือตวันี�สามารถใชแ้สดงตวัอกัษรให้ปรากฏที�พื�นที�การทาํงานของเราได ้โดยมี

ขั�นตอนดงันี�  

1) ใหค้ลิกเลือกที�เครื�องมือ Text Tool ดงัภาพ 
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2) กาํหนดคุณสมบติัที�หนา้ต่าง Properties โดยกาํหนดชนิดของ Text ใหเ้ลือกเป็นแบบ Dynamic 

Text แลว้วาดลงไปที� Stage ดงัภาพ 

 
3) วาด Text  ลงบนพื�นที�การทาํงาน คลิกที� Text แลว้ตั�งชื�อใหก้บั Text ดงัภาพ 

 
4) สร้าง layer ใหม ่แลว้ตั�งชื�อวา่ action ที�เฟรมที� 1 กดปุ่ม F9 แลว้พิมพโ์คด้ดงัต่อไปนี�  

 
 ให้สังเกตบรรทดัที� 4 เป็นการกาํหนดค่าประโยคที�วา่ “Hello! Action Script” ให้กบักล่อง

ขอ้ความที�เราไดส้ร้างขึ�นโดยการอา้งชื�อในที�นี� คือ txtName ผลลพัธ์จากการทาํงานคือเมื�อคลิก

ปุ่มชื�อวา่ btnEnter จะทาํใหเ้กิดขอ้ความขึ�นที�กล่องขอ้ความชื�อวา่ txtName นั�นเอง 
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7. การทาํงานกบัมูฟวี;คลปิ (Movies Clips) 

คุณสมบติัของมูฟวี�คลิป  

 เราสามารถกาํหนดคุณสมบติั (Properties) ของมูฟวี�คลิปแต่ละตวัที�สร้างขึ�นใหมี้ลกัษณะที�แตกต่าง

กนั และมีการทาํงานที�แตกต่างกนัได ้คุณสมบติัที�สาํคญัที�ควรทราบ ของมูฟวี�คลิปมี ดงัต่อไปนี�  

1) _x  หมายถึงกาํหนดตาํแหน่งของมูฟวี�คลิปในแนวแกน x 

2) _y หมายถึงกาํหนดตาํแหน่งของมูฟวี�คลิปในแนวแกน y 

3) _xscale หมายถึงกาํหนดขนาดของมูฟวี�คลิปขยายในแนวแกน x 

4) _yscale หมายถึงกาํหนดขนาดของมูฟวี�คลิปขยายในแนวแกน y 

5) _width หมายถึงกาํหนดความกวา้งของมูฟวี�คลิป 

6) _height หมายถึงกาํหนดความสูงของมูฟวี�คลิป 

7) _visible หมายถึงกาํหนดการมองเห็นของมูฟวี�คลิป 

8) _rotation หมายถึงกาํหนดการหมุนของมูฟวี�คลิป 

การควบคุมมูฟวี�คลิป 

 การเขียนควบคุมการทาํงานของมูฟวี�คลิปโดยใชค้วามรู้จากคุณสมบติัของมูฟวี�คลิป 

มีขั�นตอนดงันี�  

1) ลากมูฟวี�คลิปที�ไดส้ร้างไวแ้ลว้จาก Library Panel ดงัภาพ 

 
2) คลิกเลือกที�มูฟวี�คลิป แลว้ตั�งชื�อที� Properties ดงัภาพ 
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3) สร้าง layer ใหมต่ั�งชื�อวา่ action คลิกที�เฟรมที� 1 กดปุ่ม F9 เพื�อเขียนโคด้ 

4) เขียนโคด้ดงัต่อไปนี�  

 
5) กด Ctrl+Enter เพื�อทดสอบการทาํงานของ Movie 

 

8. การทาํงานกบัเมาส์และคีย์บอร์ด 

การทาํงานกบัเมาส์ โดยใชว้ธีิ Drag and Drop มีขั�นตอนดงันี�  

1) ลากมูฟวี�คลิปที�ไดส้ร้างไวแ้ลว้จาก Library Panel ดงัภาพ 

 
2) คลิกเลือกที�มูฟวี�คลิป แลว้ตั�งชื�อที� Properties ดงัภาพ 
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3) สร้าง layer ใหมต่ั�งชื�อวา่ action คลิกที�เฟรมที� 1 กดปุ่ม F9 เพื�อเขียนโคด้ 

4) เขียนโคด้ดงัต่อไปนี�  

 
 

การทาํงานกบัคียบ์อร์ด เพื�อควบคุม Movie Clips มีขั�นตอน ดงันี�  

1) ลากมูฟวี�คลิปที�ไดส้ร้างไวแ้ลว้จาก Library Panel ดงัภาพ 

 
2) คลิกเลือกที�มูฟวี�คลิป แลว้ตั�งชื�อที� Properties ดงัภาพ 

 
3) สร้าง layer ใหมต่ั�งชื�อวา่ action คลิกที�เฟรมที� 1 กดปุ่ม F9 เพื�อเขียนโคด้ 
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4) เขียนโคด้ดงัต่อไปนี�  

   
  

9. การทาํงานกบัไฟล์มีเดีย (Media) 

เสียง (Sounds) 

 เสียงถือวา่เป็นส่วนประกอบสาํคญัในงานแฟลช การนาํเสียงเขา้มาใชง้านในแฟลชโดยใช ้Action 

Script มีดงันี�  

1) นาํไฟลเ์สียงที�เตรียมไวแ้ลว้เขา้มาในแฟลช  

โดยคลิกที�เมนู File -> Import -> Import to Library ดงัภาพ 

 



2) คลิกขวาไฟลที์�ตอ้งการ 

3) คลิกเครื�องหมายถูกที� 

(ควรเป็นภาษาองักฤษและไมซ่ํ� ากบัไฟลเ์สียงอื�น

4) สร้าง layer ใหมต่ั�งชื�อวา่ 

 

 

 

ไฟลที์�ตอ้งการ เลือก Properties  ดงัภาพ 

 
คลิกเครื�องหมายถูกที� Export for Action Script ที�ช่อง Identifier พิมพชื์�อไฟลเ์สียงตามตอ้งการ 

ควรเป็นภาษาองักฤษและไมซ่ํ� ากบัไฟลเ์สียงอื�น) แลว้คลิกปุ่ม OK ดงัภาพ

ใหมต่ั�งชื�อวา่ action คลิกที�เฟรมที� 1 กดปุ่ม F9 เพื�อเขียนโคด้ 
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พิมพชื์�อไฟลเ์สียงตามตอ้งการ 

ดงัภาพ 
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5) เขียนโคด้ ดงัต่อไปนี�  

 
6) กดปุ่ม Ctrl+Enter เพื�อทดสอบ Movie 

 

รูปภาพ (Images) 

  การนาํไฟลภ์าพเขา้มาใชง้านโดยใช ้Action Script มีขั�นตอน ดงันี�  

1) ใหค้ดัลอก (Copy) ไฟลรู์ปภาพที�ตอ้งการนาํมาใชเ้กบ็ไวใ้นโฟลเดอร์เดียวกนักบัไฟลแ์ฟลชของ

เรา ดงัภาพ 

 
2) สร้าง layer ใหมต่ั�งชื�อวา่ action คลิกที�เฟรมที� 1 กดปุ่ม F9 เพื�อเขียนโคด้ 

3) เขียนโคด้ ดงัต่อไปนี�  

 
4) กดปุ่ม Ctrl+Enter เพื�อทดสอบ Movie 

 

 



10. การนําผลงานไปเผยแพร่ 

การนาํผลงานที�ทาํเสร็จเรียบร้อยแลว้สามารถทาํไดด้งันี�

1) คลิกเลือกที�เมนู File -> Publish Settings

2) คลิกเครื�องหมายถูกเพื�อเลือกประเภทไฟลที์�ตอ้งการ

ในโฟลเดอร์เดียวกนักบัไฟลแ์ฟลชของเรา

เพียงแคนี่� เรากจ็ะไดไ้ฟลที์�พร้อมนาํเผยแพร่ และใชง้านแลว้

 

การนาํผลงานที�ทาํเสร็จเรียบร้อยแลว้สามารถทาํไดด้งันี�  

> Publish Settings ดงัภาพ 

 
คลิกเครื�องหมายถูกเพื�อเลือกประเภทไฟลที์�ตอ้งการเผยแพร่ แลว้คลิกปุ่ม Publish  

ในโฟลเดอร์เดียวกนักบัไฟลแ์ฟลชของเรา 

 
เพียงแคนี่� เรากจ็ะไดไ้ฟลที์�พร้อมนาํเผยแพร่ และใชง้านแลว้ 

……………………………………… 
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Publish  ไฟลที์�ไดจ้ะอยู่


